Răspunsuri

Cel mai inteligent răspuns!
2014-05-19T21:30:43+03:00
1)
int main()
{int n,i,a[50],nr=1;

cin>>n;

for (i=1;i<=n;i++)
{cout<<"a["<<i<<"]=";cin>>a[i];}

for (i=1;i<=n;i++)
 if (a[i]==a[i+1])
     nr++;
    
if (nr==n)
cout<<"Numerele sunt egale";
else
 cout<<"Numerele sunt distincte";

}

2)
int main()
{int n,u,aux,nr=0,nr2=1;

cin>>n;

aux=n;
while(aux>0)
{u%=10;
 if (u) nr++;
 aux/=10;
}
//numar cifrele din auxiliar(n)
while(n>0)
{u=n%10;
n=n/10;
if(n%10==u)
nr2++;
}
//numar toate cifrele egale+1 din n

if(nr!=nr2) //compar
cout<<"Numarul e format din cifre distincte";
else
cout<<"Numarul e format din cifre egale";
}

poti sa il scri si in pseudocod??
1)intreg n,i,a[50],nr<-1;
citeste n;
pentru i<-1,n executa
citeste a[i];
pentru i<-1,n executa
daca (a[i]=a[i+1]) nr<-nr+1
daca (nr=n) atunci
Scrie “Numerele sunt egale”;
Altfel
Scrie “Numerele sunt distinct”;
mersi