Am o problema in pseudocod si treb s-o transcriu in( c++) + inca 2 subpuncte.
citeste n(nr natural)
m=0
p=1
cat timp n>0 executa
c=n%10
daca c>0 atunci c=c-1( se termina daca)
m=m+c*p
p=p*10
n=[n/10] (se termina cat timp)
scrie m.
punctul a ) n=5172
b) transcriere in c++
c) n=? a i sa rezulte 2008

Fara raspunsuri fara sens! Daca nu stiti nu raspundeti.

1

Răspunsuri

Cel mai inteligent răspuns!
2014-04-30T22:31:00+03:00
# include <iostream>
using namespace std;
int main ()
{
int n, c,m=0,p=1;
while (n>0)
{
c=n%10;
if (c!=0)
   c--;
m=m+c*p;
p=p*10;
n=n/10;
}
cout<<m;
system ("pause");
}
// ti-am transcris pseudocodul (desi nu pot sa vad o intrebuintare logica pt programul tau
ce ide folosti la scoala (daca ai un compiler mai vechi pune iostream.h si daca fol mingw in loc de penultima linie scrie return 0;
si pt celelalte 2 puncte?
daca n=5172 ce va scrie?
la a) executi programul cu valoare data si la c) faci operatiile invers
ok multumesc!