AR PUTEA CINEVA SA-MI EXPLICE SI MIE CUM SE REZOLVA SUBIECTUL I DE LA BAC INFORMATICASubiectul I (30 de puncte) - Varianta 003Pentru itemul 1, scrieţi pe foaia de examen litera corespunzătoare răspunsului corect.1. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul realmemorat în variabila x se află în intervalul (-2,2)? (4p.)a. x*x-4<=0 b. 4-x*x>0 c. (2<x)&&(x<-2) d. (x-2)*(x+2)>0Scrieţi pe foaia de examen răspunsul pentru fiecare dintre cerinţele următoare.2. Se consideră algoritmul alăturat, descris înpseudocod.S-a notat cu x%y restul împărţirii numărului întreg x lanumărul întreg nenul y.a) Scrieţi ce se va afişa dacă se citesc, în aceastăordine, numerele: 2 5 16 9 12 13 5 0. (6p.)b) Scrieţi un şir de date de intrare, format doar dinnumere naturale cu o singură cifră fiecare, care sădetermine afişarea valorii 7310. (4p.)citeşte z,x(numere naturale nenule)┌cât timp x>0 execută│ citeşte y (număr natural)│ ┌dacă z<y-x atunci│ │ scrie x%10│ │altfel│ │ scrie y%10│ └■│ x

1
P.S: Varianta I am primit-o la un test de anul trecut :))
multumesc mult pentru ajutor!In cazul in care mai am nevoie de ajutor crezi ca ai putea sa ma ajuti?
Trimite-mi mesaj, așa îmi e mai ușor să te ajut
P.S: Am găsit variantele la http://www.ltpbetel.ro/Documente/bac2009_variante.pdf‎
Să îmi dai linkul ăsta mie și celorlaltora, nu scribd :))
ok...si multumesc din nou!

Răspunsuri

  • Utilizator Brainly
2014-03-19T09:25:45+02:00
1.a)
2.Când un număr depășește suma primelor două, se scrie ultima cifră a celui de-al doilea. Altfel, se scrie ultima cifră a respectivului.
Ai 55555
P.S: Nu ai copiat corect algoritmul (condiția cât-timp cere ca x să se modifice, dar nu am văzut nicio modificare)
Din cauza asta nu rezolv punctul b.
1 3 1