1) Se citeste un numar natural n. Sa se afiseje toate numerele naturale mai mici decat n care sunt divizibile cu 3.
2) Se citesc mai multe numere intregi pana cand ultimul numar citit este 0. Sa se calculeze suma celor de rang par si produsul celor de rang impar.
( rezolvare sub forma de algoritm)

1

Răspunsuri

2014-02-13T17:43:33+02:00
C++:
1.
#include <iostream>
using namespace std;
int main()
{
int n;
cout<<"n="; cin>>n;
for (int i=0; i<=n; i+=3)
      cout<<i<<"; ";
}

2.
#include <iostream>
using namespace std;
int main()
{
int n, i=1, s=0, p=1;
cin>>n;
while (n)
      {if (i%2==0) s+=n;
      else p*=n;
      i++;
      cin>>n;
      }
cout<<"Suma: "<<s<<" produsul: "<<p;
}

PSEUDOCOD:
1. Date de intrare: n - numar natural
Date de manevra: i
citeste n
pentru i<--0, n, +3
        scrie i " "

2. Date de intrare: n - numere naturale
Date de manevra: i
Date de iesire: s, p
i<--1
s<--0
p<--1
citeste n
cat timp n!=0 executa
      {daca i%2=0 atunci s<--s+n
                         altfel p<--p*n
      i<--i+1
      citeste n
      }
scrie s, p
Doresti algoritmul in pseudocod?
nuu, deja ii prea complicat, nu doresc pe calculator, vreau doar sa fie rezolvata in limbaj de algoritm.
Ok. am editat postarea, ai mai jos "PSEUDOCOD" :D
asa :)) multumesc!
cu multa placere! si scuze, am uitat sa il iau in considerare si pe 0. si 0 se imparte exact la 3. deci i va porni de la 0 in "pentru"